
Welcome to PageComposer.
This is an extensive on-line document that will help you gain a complete understanding of all the rich features of the 
PageComposer. It is important for the newcomer to read the Introduction, Basic Concepts and complete the lessons.
You can also read    “Graphics” and “More about Text” as and when required.
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Introduction to the PageComposer

The PageComposer is designed to be easy to use at the same time it is also powerful enough to layout complete 
newspapers and magazines in Urdu, Arabic and Farsi. 

Each document of the PageComposer consists of a number of pages. On each page of the document, you can place 
items like text blocks, graphics, etc. 

· See the urdu keyboard by pressing Ctrl-K or choose Show keyboaord from the View menu.

· To switch between Urdu and English typing, press Alt-L ( ‘L’ for language).

· To place a particular item on the page, either you can click on its icon on the toolbar (which appears 
just below the menu line of the PageComposer) or you can choose the item from the Insert menu. After
choosing the item to be placed from either the menu or the icon, you have to draw it on the page by    
moving the mouse anywhere on the page, holding the left mouse button down and dragging the mouse.

· To move an item from one place to another on the page, first select it by moving the mouse cursor 
over that item and clicking it. This way, the item will appear selected and eight handles will appear 
around its rectangular boundary. Now to move the selected item to another place, position the mouse 
cursor anywhere on the selected item’s rectangular boundary(but away from the eight handles) until the
mouse cursor changes to a four way arrow. Hold the left mouse button down and drag the item to a 
new place.

· To change the size of an item like a text block etc., first select it by moving the mouse cursor over 
that item and clicking it. This way, the item will appear selected and eight handles will appear around 
its rectangular boundary. Now to change its size, move the mouse cursor over any of the eight handles 
until the mouse shape changes to a two-way arrow. Hold the left mouse button down and drag the 
corner or the side of the item to the new size.



How Do I ...
... Edit Text?
... Insert Text from other Files?
... Make Text Flow into Columns?
... Automatically Number the Pages?
... Compose Poetry?
... Compose Ads.?
... Compose Magazines?
... Compose Newspapers?
... Compose Books?
... Use Styles?
... Use Guides?
... Use OLE?
... Make Headlines?
... Draw Rectangles, Circles and Lines?
... Print Pages that are larger than the Printer’s Page Size?



Keyboard Shortcuts

Press F1 for Help.

Text Editing Short Cuts

While editing text, a blinking line (Caret) appears on the screen. It indicates where the text editing will take place.

Special Typing Sequences

To Switch between Scripts (from Urdu to English
 and visa-versa): Alt + L
To add a page numbers Alt + N
To decrease space between words: Ctrl + Backspace
To increase space between words: Ctrl + Space

Moving the Caret

Move the Caret using Left, Right, Up and Down Keys:-

Go to the beginning of a line: Home
Go to the end of a line: End
Go to the word on the left: Ctrl + Left
Go to the word on the right: Ctrl + Right
Go to the next paragraph.: Ctrl + Down
Go to the previous paragraph.: Ctrl + Up

Text Selection, Cut/Copy/Paste

To select Text, hold the Shift Key Down, while moving the Caret with the Moving the Caret commands. 

Select the complete Text Block: Ctrl + A
Copy the selected text: Ctrl + C
Cut the selected text: Ctrl + X
Paste the selected text: Ctrl + V
Remove text: Delete 

Text Formatting

Change font: Ctrl + T

Left align: Ctrl + Shift + L



Right align: Ctrl + Shift + R

Center align: Ctrl + Shift + C

Force justify: Ctrl + Shift + F

Toggle justification: Ctrl + Shift + J

Change paragraph. settings: Ctrl + M

Change indents: Ctrl + I

Flow paragraph. Left to Right: Ctrl + Shift + Right 

Flow paragraph. Right to Left: Ctrl + Shift + Left

Undo

Undo last edit: Ctrl + Z.

Styles

Define style: Ctrl + 3

Style: Ctrl + Y

Find, Replace and Spell Check

Find: F3

Replace:  F4

Check spellings: F5

Repeat find: Ctrl + F

Repeat replace: Ctrl + U

Layout Short Cuts

Open a document: Ctrl + O

Save the current document: Ctrl + S

Print the current document: Ctrl + P

Go to a particular page: Ctrl + G

Go to the next page: Page Down

Go to the previous page: Page Up



Send the current item back: Ctrl + B



Mouse Operations

Selecting text

Creating a new Text Block.

Adding continuation Text Blocks.

Selecting an item on the page.

Selecting multiple items on the page.

Changing an item’s place.

Resizing an item.

Adding Guides.

Moving Guides.

Removing Guides.

Moving the ruler



Selecting Text
· Move the Mouse to the first word to be selected and press the Left Mouse Button. 
· While keeping the Mouse Button Down, move the Mouse Cursor rapidly to the last word to be selected. 
· The selected text will appear in reverse.



Creating a New Text Block
· Click on the text block icon (eighth icon from the left)
· Click anywhere on the page to create a    text Block of a reasonable column width.
· Alternatively, drag the Mouse Cursor. A Text Block of the marked rectangle’s size and position will be created 

on the page.
· You can also re-size the Text Block, to the desired dimensions.



Adding Continuation Text Block(s) to an Existing Text Block
The Continuation Text Blocks are also called Linked Text Blocks.
· Choose a Text Block by Clicking on it.
· Click on its lower Handle, to pick-up the Continuation Text. The Mouse Cursor now resembles a Text Column.
· Create a Continuation Text Block by Clicking or drawing a new Text Block. For placing the Continuation Text 

onto another page, you may change the page by Page-Up or Page-Down Keys.
· Hold the Shift Key Down, while creating a Continuation Text Block. A series of Continuation Text Blocks can 

be created in this manner. These will be linked.



Selecting an Item on a Page 
· Click on the item to be selected. 
· The selected item appears, with Handles.



Selecting Multiple Items on the Page 
· Move the Mouse Cursor outside all the items.
· Hold the Left Mouse Button Down.
· Drag the Mouse Cursor so that the drawn rectangle encloses the items to be selected.
· Release the Mouse Button.

All the selected items will be highlighted with a dotted rectangular border around them.



Moving an Item on the Page
· Select an item by clicking on it.
· Move the Mouse over one or the item’s solid lines until the mouse cursor shape turn into a four-way arrow.
· Hold the Left Button Down.
· Drag the Item to its new place.



Re-sizing an Item
· Select the Item by Clicking on it.
· Eight Handles will appear around the selected item.
· Drag any Handle to re-size the item.

If Snap To Guides is ON, then the moved or re-sized item will automatically align itself with a guide, if there is one 
close to it.



Adding Guides
· Move the Mouse over either of the rulers.
· Press the Left Button Down.
· Keeping the Left Button Pressed, drag the new Guide from the Ruler onto the Page.

(The guide can be placed within the page boundaries only.)



Moving Guides
· Move the Mouse Cursor directly over a Guide.
· Press the Left Mouse Button Down.
· Holding the Left Button Down, drag the Guide to the required location.



Removing Guides
· Drag the Guide outside the Page.



Changing the View

The    PageComposer 3    allows you to flip between a Complete View of the current page and a Detailed View of a 
part of the page. To switch between the two views, Click the Right Button.

When switching from Complete View to the Detailed View, move the Mouse Cursor over that part of the page that 
you wish to see and then Click the Right Button.

Tip: You can rapidly move from one part of the page to another, Switch to the Complete View with one Click. Move 
the Mouse Cursor over the part of the page you wish to see and then Click the Right Button again.



Moving the rulers’ zero point

The ruler’s zero point can be moved so that various measurement of the items on the page can be taken.

To move the zero point

· Click on the rulers icon (the third icon from the right on the tool bar)

· With click the cross-hair mouse cursor anywhere on the page to set the zero point.



Menu Commands

File::New

File::Open...

File::Close

File::Save

File::Save As...

File::Page Setup...

File::Print...

File::Print Preview

File::Printer Setup...

File::Preferences...

File::Exit

Edit::Undo

Edit::Cut

Edit::Copy

Edit::Delete

Edit::Paste

Edit::Paste Link

Edit::Paste From File...

Edit::Select All

Edit::Find...

Edit::Find Again

Edit::Replace...

Edit::Replace Again

Edit::Check Spelling

View::Keyboard

View::Toolbar

View::Statusbar

View::Column Guides

View::User Guides

View::Lock Guides

View::200%



View::100%

View::50%

View::25%

Insert::Rectangle

Insert::Pages

Insert::Lines

Insert::Circle

Insert::Rounded Rectangle

Insert::NextColumn

Insert ::Page Number

Insert::Text File…

Insert::Text Block …

Insert::Object...

Layout::Columns...

Layout::Size...

Layout::Insert Pages...

Layout ::Remove Pages...

Layout::Goto Page...

Layout::Goto Master page

Layout::Autoflow

Layout::Snap to Guides

Layout::Fill...

Layout::Line...

Layout::Text Wrap...

Layout::Send to Back

Layout::Bring to Front

Text::Font...

Text::Left

Text::Right

Text::Center

Text::Forced Justify

Text::Justification

Text::Para...



Text::Indents...

Text::Tabs...

Text::Define Styles...

Text::Styles...

Text::Left to Right

Text::Right To Left

Window::New

Window::Cascade

Window::Tile HorizontallyWindow::Tile Vertically

Window::Arrange Icons

Help::Index

Help::Using Help

Help::About



File::New (Ctrl + N)

Creates a new document with standard settings. You can modify this to suit your requirements, by Page Setup option
of File menu. When a new document is being created, it is the right time to setup all your Guides, Styles, etc.. 

It is also advisable to save an empty document, with all its Guides, Columns, Master Pages, etc. in place. Use it as a 
template It will be of help in creating other similar documents.

Creating a new publication does not close the current one.

Shortcuts

Toolbar:
Keys: CTRL+N



File::Open... (Ctrl + O)
 
Displays the standard Windows File Open dialog box. The    PageComposer 3  files have the extension.pc2. If OK is
Clicked, after selecting a valid file, it is opened in a separate Child Window.

The    PageComposer 3    allows you to open a number of files, simultaneously. This is a great help for doing 
cut/copy/paste jobs, across the documents.

 Opening a publication does not close the current one.

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you select in the List Files 
of Type box. 

List Files of Type
Select the type of file you want to open:

Drives
Select the drive in which PageComposer stores the file that you want to open. 

Directories
Select the directory in which PageComposer stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 

Shortcuts

Toolbar:
Keys: CTRL+O



File::Close

Closes the Currently open publication. It also prompts the user to save the document, if it has been modified.

Note that, many documents may be opened simultaneously, but this command will close only the current document (
the one with the Window Active ).



File::Save

Saves the currently active document ( the one with the Window Active ). If the document is untitled as yet, then the 
File SaveAs dialog is presented to the user.

If the publication contains embedded OLE items, then these are also saved within the document file. In order to 
decrease the size of a document file, the OLE items can be linked, instead of being embedded. Refer to the 
discussion under Edit::Insert Object... for more details.

Shortcuts

Toolbar:
Keys: CTRL+S



File::Save As...

Prompts the user to give a name and a path for storing the publication file. The standard File Save dialog box is 
presented. If a file of similar name and path already exists, then the user is prompted to either overwrite the existing 
file or abort the file saving procedure.

The following options allow you to specify the name and location of the file you're about to save:
File Name

Type a new filename to save a document with a different name.    A filename can contain up to eight characters 
and an extension of up to three characters.    PageComposer adds the extension you specify in the Save File As 
Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



File::Page Setup...

You can change the page size and margins of your publication, with the Page-Setup dialog. 

It is preferable to set the Page Size before starting a new document.

Columns Left to Right / Right to Left : Sets the direction of the columns For Urdu/Arabic/Persian documents, the 
columns have to flow from Right-to-Left, whereas, for pre-dominantly English/Latin based documents, it should be 
the other way round.

Tall, Wide: Use the Tall/Wide Radio Buttons to change the orientation of the page.

Left, Right, Top, Bottom Margins: Margins from each edge of the page. The units displayed are the current units of 
measure. You can always type in any other Units of Measure (mm, ins or pc,etc.,)



File::Preferences...

The Preferences dialog gives you the facility to set the units of measurefor the Rulers and the Dialog items.

By Dialog items, we mean the units of measures being used to measure the items (like in Layout::Size    or 
Layout::Columns).

The units of measurement in the    PageComposer 3    can be inches, centimeters, millimeters, picas (6 picas = 1inch)
or points (72.27 points = 1 inch). The preferences dialog allows you to set the units of measure of the horizontal and 
the vertical rulers as well as the dialog items. The dialog items always display the units of measure along with the 
value. For instance “2in” or “.75cm” or “39.05mm”. 

Every measurement in the dialogs has the value followed by the units of measure. The units of measure are denoted  
two letter combinations. These are “in” for inches, “cm” for centimeters, “mm” for millimeters and “pt” and “pc” for
Points and Picas.

If you do not specify the units of measure and just type in a number, then by default, the units of measure set in the 
preferences dialog are used.



File::Print...

The PageComposer 3 provides the standard Windows Print Dialog Box. You can print any range of pages or the 
whole document. As the print dialog box is standard, you can refer to the Windows document for further 
explanations about it.

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the printer and printer 
connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to produce.

Shortcuts

Toolbar:
Keys: CTRL+P



File::Printer Setup...

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



File::Print Preview

Print Preview offers an on-screen preview of the actual print-out expected. Print Preview uses the attributes of the 
currently selected printer to simulate the printer’s output on the computer display. This is of use when the printer 
capabilities are different from the displays. For instance, if the printer doesn’t support color printing, then 
previewing the print-out is useful in finding out how exactly the print-out will look in black and white.

The print preview toolbar offers you options to view either one or two pages at a time; move back and forth 
through the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



File::Exit

Use this command to end your PageComposer session.    You can also use the Close command on the application 
Control menu.    PageComposer prompts you to save documents with unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Edit::Undo    (Ctrl + Z)

Will reverse the effects of the last operation. Not all the operations are undo-able. For instance, when you delete a 
frame, it is placed on the Clipboard. To undo the deletion of the frame, you can select Paste from Edit menu to place 
it back on the page.

The Undo operation are only applicable to Text-Editing operation in this release.



Edit::Cut    (Ctrl + X)

Removes the Current Selection and places it on the Clipboard. To place the Current Selection on the Clipboard, 
without removing it from the Current page, use Edit::Copy.

The selection can be of one or more items. You can paste the items you have cut into another documents opened 
inside the    PageComposer 3    or in another document of another program. If you have placed it in another program,
the selection will be pasted as a picture (Metafile format or Bitmap format).

The text selection will be placed on the Clipboard and removed from the page.

Shortcuts

Toolbar:
Keys: CTRL+X



Edit::Copy    (Ctrl + C)

Copies the current selection to the Clipboard. To remove the current selection while copying it, refer to Edit:: .

The selection can be of one or more items. You can paste the items you have copied into other documents opened 
inside the    PageComposer    3 or in any other document of another program. If you have placed it in another 
program, the selection will be pasted as a picture (Metafile format or Bitmap format).

The text selection will be placed on the Clipboard .

Shortcuts

Toolbar:
Keys: CTRL+C



Edit::Delete    (Delete Key)

Removes the current selection (either text or item(s)) and places it on the Clipboard. To place the current selection 
on the Clipboard, without removing it from the current page, use Copy.



Edit::Paste    (Ctrl + V)

Inserts the current    Clipboard contents onto the current page.

To paste text, you first need to position the Caret on the Text Block where you wish to paste the text and then choose
the Paste command.

To paste items Copied/Cut from other programs or other    PageComposer 3    documents, choose Paste. 

Shortcuts

Toolbar:
Keys: CTRL+V



Edit::Paste Link

Inserts an OLE object as a linked item (See How do I ... Use OLE?).

When you choose Paste Link, instead of Paste command, the contents of the    Clipboard are not included in the 
saved document file (only a reference to the file that actually contains the    Clipboard data is saved in the document 
file). This substantially reduces the size of your document files. 

The disadvantage of pasting an OLE item is that, if the file referred to is missing (for example you copy the 
document to another machine without copying the linked files along with it), then the OLE items will not be 
displayed.



Edit::Paste From File...

Pastes the contents of a plain ASCII file or a Urdu Composing System (UCS extension file) at the current    Caret 
position, using the current font, paragraph and indents settings.    

Position the Caret and then choose Paste From File command.



Edit::Select All    (Ctrl + A)

if no text block is selected,    chooses all the items of the current page.
If a text block is selected, then the entire.text of current block is selected.

Note:Make a block current, by Clicking inside it.



Edit::Find... (F2)

Locates the occurrence of a particular sequence of letters (words) in the document, commencing from the current 
position of the Caret. You can enter, both, Urdu and English words. Use the Radio Buttons to choose either Urdu or 
English ‘Find’. 

This commands places the Cursor on the first occurrence of the given sequence of letters. To find the next 
occurrence, use Find Again command



Edit::Find Again    (F3)

Locates the next occurrence of the sequence of letters specified in the previous Find.. operation.



Edit::Replace... (F4)

Finds a sequence of letters (words) in the document and replaces them with another specified sequence. Enter the 
sequences of the letters to be found and the sequence to be substituted with. You can specify the script by choosing 
either Urdu or English Radio Button.

The PageComposer 3 prompts the user before the actual substitution.



Edit Replace Again... (F5)

Replaces the next occurrence of the letters as specified in the previous Replace operation.

The PageComposer 3 prompts the user before the actual substitution.



Edit::Check Spelling... (F6)

Checks the spellings of the document starting from where the    Caret    is placed. For each word not found in the 
internal dictionary of the PageComposer 3, the user is prompted to either skip the word, add the word to the 
dictionary or end Spell Checking.



View::Keyboard

Displays the current Keyboard Press Ctrl+K



View::Toolbar

Use this command to display and hide the Toolbar, which includes buttons for some of the most common commands
in PageComposer, such as File Open.    A check mark appears next to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in <<YourApp>>,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Open a new document.

Open an existing document.    PageComposer displays the Open dialog box, in which 
you can locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, PageComposer displays the Save As dialog box.

Remove selected data from the document and stores it on the clipboard.

Copy the selection to the clipboard.

Insert the contents of the clipboard at the insertion point.

Print the active document.

 Displays the about the author details.

Click this icon for help.

Select the Arrow Cursor to Select the item on the page.

Select the I-Cursor to Edit.

Create line with this icon.

Create rectangle with this icon.

Create circle with this icon.

Create rounded rect with this icon.





View::Statusbar

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the PageComposer window.    To display or hide 
the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
PAGENO Display Page No.
FONT Display current Font size and Font name.
STYLE Display current style.



View::Column Guides

Displays or hides the Column Guides. The Column Guides are created by Layout Columns



View::User Guides

Displays or hides the User Placed Guides. The User Guides are created by dragging them out of the rulers.

To remove the User Guides, drag them outside the page outline.



View::Lock Guides

Locks Guides so that the user does not move them by mistake. You should lock the guides if your page layout is 
going to remain constant. 



View::200%

Sets the detailed view to 200% of the actual size. Use this for fine alignment and text placement.

Change to    full page view    by Clicking the right Mouse Button in the detailed view.

To see a particular part of the page in detailed view, move the Mouse Cursor over that part and right Click the 
Mouse Button again.



View::100%

Sets the detailed view to 100% . This is approximately the size of the physical page on a 14” display of 1024 by 768 
resolution. The actual view will vary, depending upon the display size, etc.

Change to full page view by Clicking the right Mouse Button in the detailed view.

To see a particular part of the page in detailed view, move the Mouse Cursor over that part and right Click the 
Mouse Button again.



View::50%

This is the default detailed view settings. Use it for most of your text editing work.

Change to full page view by Clicking the right Mouse Button in the detailed view.

The see a particular part of the page in detailed view, move the Mouse Cursor over that part and right Click the 
Mouse Button again.



View::25%

Sets the detailed view settings to 25% of the actual size. Use this for placement/viewing of bigger objects.

Change to full page view by Clicking the right Mouse Button in the detailed view.

The see a particular part of the page in detailed view, move the Mouse Cursor over that part and right Click the 
Mouse Button again.



View::Goto Page... (Ctrl + G)

Changes the current page. The current page number is also displayed on the bottom status bar.



View::Goto Master Page

Makes the Master Page your current page. All items placed on the master page are printed on every page of the 
document. 

The Master page is a special page. Its contents are visible and printed on every page of the document.

It is preferable to place the Headers, Footers, Page Numbering markers, etc. on the Master Page, as well as Guides 
on the Master Page, for achieving consistent layout of all pages.



Insert:: Object...

Inserts an OLE object on the page. Read the article (How do I use ... Use OLE?).
The standard OLE Insert Object dialog is presented. 

There are two ways that a user can place an OLE object on the current page.

First, a new object can be created by choosing one of the several OLE servers listed in the dialog box.

Second, an existing OLE object’s file can placed on the page by first choosing Create From File and then choosing 
the filename for the OLE object (like a BMP file) from the existing files on the system.

If you choose to place the object as a link, then the actual object’s data is not stored by the document file.

PageComposer 3. Instead, only its reference (as a filename) is stored. This cuts down on the storage requirement of 
your    PageComposer 3  files. On the other hand, if you forget to copy the linked files, while moving your 
PageComposer 3 files, from one system to another, you will not be able to display the linked items on the page.

To edit an OLE object on the page, just double-Click on it.



Insert::Pages...

Inserts a number of pages either before or after the current page. You can add any number of pages (upto a 
maximum of 999). Add pages as and when required. Unnecessarily adding empty pages may slow down the    
PageComposer 3’s    performance.



Insert::Line
Selects the line draw tool. 
· Move to the pasteboard and drag the mouse to draw.
· Press the left mouse button down to start drawing and move the mouse.
· Release the left mouse button to complete drawing.
The line drawn will use the current attributes set in the line dialog box (open the Line dialog box by choosing 
“Line…” from Layout menu).



Insert::Circle
Selects the Circle draw tool. 
· Move to the pasteboard and drag the mouse to draw.
· Press the left mouse button down to start drawing and move the mouse.
· Release the left mouse button to complete drawing.
The circle drawn will use the current line attributes set in the line dialog box (open the Line dialog box by choosing 
“Line…” from the Layout menu).
0 The circle drawn will use the current fill attributes set in the fill dialog box (open the Fill dialog box by 
choosing “Fill…” from the Layout menu).



Insert::Rectangle
Selects the Rectangle draw tool. 
· Move to the pasteboard and drag the mouse to draw.
· Press the left mouse button down to start drawing and move the mouse.
· Release the left mouse button to complete drawing.
The rectangle drawn will use the current line attributes set in the line dialog box (open the Line dialog box by 
choosing “Line…” from the Layout menu).
0 The rectangle drawn will use the current fill attributes set in the fill dialog box (open the Fill dialog box by 
choosing “Fill…” from the Layout menu).



Insert::Rounded Rectangle
Selects the Rounded rectangle draw tool. 
· Move to the pasteboard and drag the mouse to draw.
· Press the left mouse button down to start drawing and move the mouse.
· Release the left mouse button to complete drawing.
The rounded rectangle drawn will use the current line attributes set in the line dialog box (open the Line dialog box 
by choosing “Line…” from the Layout menu).
The rounded rectangle drawn will use the current fill attributes set in the fill dialog box (open the Fill dialog box by 
choosing “Fill…” from the Layout menu).



Insert::Page Number
Inserts the page numbering on your document. It inserts the page number marker into the current editing position. If 
currently no text block is selected, then the page numbering procedure will promote you and automatically place the 
page marker on the master page.
The page number is a special character that generates the current page number on which ever page number it 
appears. Choosing “Insert::Page Number” will insert this special character into your text.
The easiest way of automatically numbering your document is to place the the page number marker on your master 
page (either above the top margin or below the bottom margin). As the master page is visible on every page of the 
document, the page number will then automatically appear on every page of your document.



Insert::Text File
The PageComposer can place regular English ASCII text files as well as Urdu files created in the Text Editor 
supplied with the PageComposer (please read about the Text Editor elsewhere in the document.
The files created in the Text Editor have .UCS extension (which stands for our old program called the Urdu 
Composing System). These files can be inserted into any text block.
These files can also specify their own styles. This is discussed under the topic of More on Text     in the User manual 
(see the table of contents)



Insert::Text Block
This command allows you to add a new text block to the page. 
After choosing this menu item, the cursor will change to a text block.
With the text block cursor, you can click on any column of the page and start a text block in that column
To create a text block of a specific size (and not the size of the columns set for the document)
· Move the mouse cursor to the page. Press the left mouse button down.
· Keeping the left button pressed, drag the mouse to mark the area for the new text block. 
· Release the mouse.
Now you can type in the new text block



Insert::Next Column
The next column is required when you want to add a link a new text block to the old one. The text of linked text 
blocks flows from one text block to another as the text blocks keep getting filled.
Removing text in a block will bring in more text from the next block in the link so.
To create a linked text block
· Select a text block.
· Click on its lower handle (the mouse cursor will turn to a text block)
· With the text block, you can create its continuation text block by either clicking inside a column (on any page of

the document) or drawing it

If the Autoflow is kept on, then the linked text blocks are automatically created.



Layout::Columns...

Sets the Column Guides on the page. Specify the number of columns to be created and the amount of gap to be left 
between the columns. Creates equally spaced column guides on the current page. 

To create columns of uneven widths, first create the columns as above and then drag the column guides to create 
unevenly spaced Columns.

If columns are created on the master page, then every new page inserted will also carry the same column settings. 

To edit text in a column, click inside the column. Now you can type/edit the text inside that column. If the 
Layout::Autoflow is ticked ON, then, once the text in one column is full, it will overflow to the next column. 
(Additional pages are created if the text flows beyond the last column of the last page.)The units of measure are 
displayed as a number followed by the units of measure



Layout::Size...

See and modify the size of a selected item on the page. The measurement appear in the units selected in the dialog of
File::Preferences.

The units of measure are displayed as a number followed by the units of measure.

These units of measure can be inches, centimeters, millimeters, points or picas. You can override the current units of 
measure by suffixing the measurements with its units. Certain examples of entering the units of measurements in the 
PageComposer    3 are:- “2.5in”, “.5pt”, “23.43cm”, “20.8pc”, “34mm” . The invalid ones being:- “in1.2” (the “in” 
should appear after the number), “27 mm” (there is a space between the number and the units of measure).

The valid units of measure are:-

“in” Inches

“cm” Centimeters

“mm” Millimeters

“pc” Picas (1/6th of an inch)

“pt”Points (1/72th of an inch



Layout ::Remove Pages...

Remove a number of pages either before or after the current page. All the items of the pages that are being removed 
are deleted, except for the text in the linked Text Blocks The text of the removed linked blocks is automatically 
pushed into the nex linked Text Blocks of the following pages.



Layout::Autoflow

Autoflow enables the    PageComposer 3  to automatically place text in Multiple Text Blocks , forming Columns on 
each page and adding on pages as necessary. The multiple Text Blocks will be linked to each other as a running text.

To manually create Text Blocks linked to an existing Text Block, choose a    Text Block and Click on its Lower 
Handle. The Mouse Cursor will turn into a Column Shaped Cursor. With this Column Cursor, Click inside the 
column guides to create continuation columns.The Column Cursor will disappear after each operation. 

With the Column Cursor, you can also draw a rectangle, of any size/shape anywhere on the column(s) to mark the 
area of the    Continuation Linked Text Block.

To create multiple Text Blocks, hold Down the Shift Key. Then move the Column Cursor on to the any column and 
Click. Text will flow into that column. Similarly, multiple Text Blocks can be created, till such time the Shift Key 
remains pressed.( The Column Cursor will be retained, till such time the Shift Key remains pressed).



Layout::Snap to Guides

Turn on the Snap to Guides, if you wish to automatically align all your items to User Guides and Column Guides. 



Layout::Fill...

Select the Fill settings for a selected Rectangle, Circle or Rounded Rectangle and Future Drawing.

The Fill setting consists of a pattern and a color.

Choose “-none” as the pattern, if you wish to keep the shape hollow. (Which means it will be transparent and the 
item behind it will be visible).

If you choose a color, the Pattern setting is automatically taken to be Solid. You can specify a pattern as well as 
color.

On Clicking OK on the Fill Dialog box, the attributes of the shape, if already selected, will change to that of the new
setting.



Layout::Line...

Select the Line Drawing settings for a Selected Line, Rectangle, Circle or Rounded Rectangle and Future Drawing.

The Line setting consists of specifying widths of two lines, the intervening space and the line color.

To draw a simple line, keep the second line width ‘zero’. 

To draw a double line, make the second line width and the spacing a non-zero value.

The lines widths and spacing are best specified in Points sizes 

On Clicking OK on the Fill Dialog, the attributes of the shape, if already selected, will change to that of the new 
setting.



Layout::Text Wrap...

Make the text of the page wrap around the selected item. When an item’s text wrap is switched ON, then text of the 
page doesn’t flow over the item.

Specify a stand-off margin so that the text flow stops some distance from the edges of the item.

When you move a text-wrapped item on the page to a new location, the text doesn’t automatically reflow. To trigger 
the text flow of a particular    Text Block around the text-wrapping item, change the    Text Block’s size slightly. By 
manually triggering the text flow, you can choose the text which should avoid the item or be wrapped.

When the item for which text wrap is selected has a text block completey inside it, the text wraps inside its 
boudaries and it the text blocks only partially overlap the selected item, then the text wrap is around it.



Layout::Send to Back    (Ctrl + B)

Sends the selected item to the back of the page. All the other overlapping items appear on top of that item.



Layout::Bring to Front    (Ctrl + F)

Brings the selected item to the front of the page. All the other overlapping items appear under that item.

Whenever you select a frame, it is automatically brought to the top. This command is included basically for 
compatibility with the other software.



Text::Font... (Ctrl + T)

Changes the current fonts settings.The font setting can be changed either for the text to be entered, after effecting the
font change or only the selected portion.    In the latter case, the new font specifications will apply to the highlighted 
text only.

Two typefaces, one in Urdu and the other in the English, can specified in the font settings. Both the typefaces can 
have individual type sizes. This is to facilitate working with fonts as a pair of Urdu/English combination

The PageComposer 3 does not accept the non-TrueType Windows fonts.

The TrueType fonts can be specified as - bold, italics or underlined. The Urdu fonts can also be specified by their 
width and slant.

The Urdu Fonts cannot have Bold and italics as attributes. This is, because the calligraphic content will suffer if the 
fonts are made bold or italicised. The compositor is, nevertheless, called upon to set the text in in a condensed or 
slanted form . For such purposes, use Slant and Width attributes of the Font dialog.

 A width and slant of 100% is the normal recommeded setting. To make the font look narrower or broader, the width 
maybe varied between 1 and 250%. Similiarly, the font maybe slanted by +100 to -100 (toward left and right 
espectively).

A color can also be specified for each font



Text::Left    (Ctrl + Shift + L)

Aligns and sets the current paragraph and alignment to the Left. If text is selected, all the paragraphs within the text 
selection are Left aligned.



Text::Right    (Ctrl + Shift + R)

Aligns and sets the current paragraph and alignment to the Right. If text is selected, all the paragraphs within the text
selection are Right aligned.



Text::Center    (Ctrl +Shift + C)

Aligns and sets the current paragraph and alignment to the Center. If Text is selected, all the paragraphs within the 
Text selection are Center aligned.



Text::Forced Justify    (Ctrl + Shift + J)

Sets the current alignment to Force Justified. This aligns the current paragraph to expand every    line to both the 
edges of the selected Text Blocks. It also sets the current alignment to Force Justify.



Text::Justification    (Ctrl + Shift + J)

Turns Justification ON/OFF. Toggles the current and paragraph Justification setting. If the Justification is turned ON,
then all lines of the paragraph entered but the last line of the paragraph, are justified. If text is selected, justification 
for all the paragraphs within the selection is toggled. 



Text::Para... (Ctrl + Shift + M)

Sets the current paragraph attributes and that of the selected paragraphs.

The following attributes can be set/changed for every paragraph :-

Alignment: The text can be aligned Left, Right, Centered or Forced to Justify.

Justification: Line justification    can be turned ON/OFF.

Right to Left/Left to Right flow: Set the overall flow direction of the text.

Always on the Top: With this attribute ON, the selected or current paragraph(s) will always appear at the top of a 
fresh    Text Block(s).

Always at the Bottom: With this attribute ON, the selected or current paragraph(s) will always appear at the bottom 
of the subsequent Text Block(s).

Space Above the Paragraph: The vertical space to be left above the paragraph.

Space Below the Paragraph: The vertical space to be left below the paragraph.



Text::Indents... (Ctrl + I)

Sets / changes the indents of the current paragraph or the selected paragraphs, if text is selected.

The following indents can be specified:-

First Line: The space to be left before the first word of the paragraph(s).

Left: The space to be left on the left hand side of each line of the paragraph(s).

Right: The space to be left on the right hand side of each line of the paragraph(s).

Units of measurments

These units of measure can be:- “inches (in)”, “centimeters (cm)”, “millimeters (mm)”, “points (pt)” or “picas (pc)”. 
You can override the current units of measure by suffixing the desired one; enter the number, followed by the unit of
measure, without space. For instance, the following are valid measurements:- “2.5in”, “.5pt”, “23.43cm”, “20.8pc”, 
“34mm”, but not : - “in1.2” (the “in” should come after the number) or                    “27 mm” ( there is a space between
the number and the units of measure).

The valid units of measure are:-

“in” Inches
“cm” Centimeters
“mm” Millimeters
“pc” Picas (1/6th of an inch)
“pt”Points (1/72th of an inch



Text::Tabs...

Sets / changes the tabs of the current paragraph or the selected paragraphs, if text is selected.

Upto eight tabs can be specified. The    PageComposer 3    will assign a default tab setting, otherwise. The default 
setting is quite adequate for most of the tabulation work.

Each tab is specified as a width in the current units of measure.



Text::Define Styles... (Ctrl + 3)

You can define a number of text Styles. Each text style has to be assigned a user defined name. Each style defines 
the exclusive attributes of the text, such as the Font, point sizes, Paragraph attributes, Indents, etc., for English and 
non-English typefaces .

By defining the settings of a style, you automatically affect the format, font,indents, and paragraph settings of all the
paragraph(s) which the style was applied to.

A style can be applied to a paragraph in the manner similar to that of the font.

To create a new style, select an existing style name and Click on    New    Button. Enter the name of the    New Style   
in the Add New Style    dialog. The New Style name will appear in the    Styles List    box., but with the settings of 
the previous one being retained.

To modify the existing style settings, select the New style name from the list box and choose Font, Paragraph and / 
or Indents, to edit the respective aspects of the Style.



Text::Styles... (Ctrl + Y)

Select a Style from the style dialog. The selected style is made the current style. It will be applied to the current 
paragraph and to the current selection, if text is selected.



Text::Left to Right    (Ctrl + Shift + Right Arrow Key)

Sets the overall paragraph text direction, from left to right. Use it for English text or English text with 
Urdu/Arabic/Persian in it.

Applies to the current paragraph and the current selection, if text is selected.



Text::Right To Left    (Ctrl + Shift + Left arrow Key)

Sets the overall paragraph text direction, from right to left. Use it for Urdu/Arabic/Persian text.
Applies to the current paragraph and the current selection, if text is selected



Window::New

Use this command to open a new window with the same contents as the active window.    You can open multiple 
document windows to display different parts or views of a document at the same time.    If you change the contents 
in one window, all other windows containing the same document reflect those changes.    When you open a new 
window, it becomes the active window and is displayed on top of all other open windows.



Window::Cascade

Arranges all the windows of the    PageComposer 3    in a neat, overlapping manner. The title bars of each window 
will be distinctly visible. 



Window::Tile Horizontally

Rearranges all the windows of the    PageComposer 3. None will overlap the other. All the windows will be of the 
same size.



Window::Tile Vertically

Rearranges all the windows of the    PageComposer 3. None will overlap the other. All the windows will be of the 
same size.



Window::Arrange Icons

Use this command to arrange the icons for minimized windows at the bottom of the main window.    If there is an 
open document window at the bottom of the main window, then some or all of the icons may not be visible because 
they will be underneath this document window.



1, 2, ... command (Window menu)

PageComposer displays a list of currently open document windows at the bottom of the 
Window menu.    A check mark appears in front of the document name of the active window.  
Choose a document from this list to make its window active.    



Help::Index

Displays a list of Help topics. You can find information about any of the listed topics by Clicking on it.



Help::Using Help

Provides Help in how to use the help facility of PageComposer 3



Help::About

Displays the Copyright information and other details on    PageComposer 3



Context Help command 

Use the Context Help command to obtain help on some portion of <<YourApp>>.    When 
you choose the Toolbar's Context Help button, the mouse pointer will change to an arrow 
and question mark.    Then click somewhere in the <<YourApp>> window, such as another 
Toolbar button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the PageComposer window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    PageComposer 
determines which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    <<YourApp>> 
determines which window is previous according to the order in which you opened the 
windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.



How do I Edit Text ?

Creating    Text Blocks

The PageComposer 3 organizes text into    Text Blocks. 

To create a    Text Block, Click on the text block icon and Click at any point on the page.

A blinking    Caret will appear. Now, you can start typing.The text will appear following the    Caret.

The standard    Text Blocks are created as Columns between the Column guides of the page.    To create a    Text 
Block of a particular size, instead of Clicking, draw a rectangle with the Mouse Cursor with the Text block cursor 
(click on the choose Insert::Text Block to get the text block cursor).

Typing text in English and non-English scripts (e.g. Urdu/Arabic/Persian, etc.) 
Use Alt + L to switch between the scripts.

Although each script follows its own direction of writing (for instance, Arabic is written from right to left and 
English, left to right), it is essential to manually set the direction of overall text flow. This will indicate to the    
PageComposer 3    whether English is being mixed in an Arabic text or vise-versa.

Set the over-all paragraph direction by choosing either Left to Right or Right to Left options in the Text menu.

Note: The respective Keyboard short cuts are: Ctrl+Shift + Right and Ctrl + Shift + Left.

Choosing Fonts

The PageComposer 3 provides you with a powerful facility for choosing English and a non-English typefaces as a 
combination, as if for a single font. For instance, you may wish to work with ‘Mukkaram’ in 13pt (Arabic) font, with
the English text being in ‘Arial’ - 10pts. This gives you a powerful way choosing any combination of the typefaces 
of the two languages in use
.
Choose Fonts    from Text menu or use Ctrl + T to access the fonts dialog box.

Also see 

Text::Left,

Text::Right, 

Text::Center,

Text::Force Justify

Text::Justification, 

Text::Para,

Text::Indents,

Text::Tabss,



Edit::Copy,

Edit::Cut,

Edit::Paste,

Edit::Undo,

Edit::Replace,

Edit::Find.



How do I Insert text from other files ?

PageComposer 3 has two simple ways of inserting text from other files.

1. Using the    Clipboard.

Open the file in whichever program you had originally created it in and copy all the text to the    Clipboard; by using 
that program’s Copy command. Place the    Caret wherever you wish to begin inserting the text in the 
PageComposer 3 document and choose Paste from the edit menu (Ctrl + V).

2. Paste From File

PageComposer 3 allows you to directly choose plain ASCII text files and files created by Computer Corporation’s
“Urdu Composing System/1”  or its clones (for Urdu/Arabic/Persian software).

Place the    Caret where you want the text to be inserted.

From Edit menu, choose Paste from File.

From the files dialog box, choose the file to be placed.
Click on OK.



How do I Make Text Flow into Columns ?

PageComposer 3 makes it very easy to flow text into columns.

Automatically Flowing Text into Columns and Pages

To type text that should flow into one column after another, proceed as follows:-

Turn on the Autoflow option in the Layout menu, by choosing it once 

Click inside any column on the page.

Type or paste text. The text will automatically flow into multiple columns, creating    Text Blocks in each one. 
Additional pages are automatically added, if necessary. 

Manually Flow Text into Multiple Columns and    Text Blocks.

Turn Off the Autoflow option in the Layout menu (the check mark against it should disappear).

Select the Text Block by Clicking inside it.

Click on its lower Handle. The Mouse Cursor will now resemble a text column.

Move the Mouse Cursor to where-ever you want the next column to be created and release the text column Cursor, 
by Clicking again. You could also change the page by Page Up or Page Down Key to place the next column onto 
another page).

To create more than one column, hold the shift Key Down, while Clicking with the text column Cursor. In this 
manner, you can create multiple    Text Blocks., without releasing the text column Cursor.



How do I Automatically Number the Pages ?

Position the caret at the exact point on the page where you wish to place the page numbers.

Type Alt + N to invoke the    Page Number Marker. The current page number will be displayed.

The page numbers will be printed at the designated location on each page of your document.



How do I Compose Poetry ?

Poetry is one of the toughest jobs for a compositor. Aesthetics play a major role in. formatting it.
.
Poetry requires lines of equal length. You can do this by changing the alignment of the whole poem to Forced 
Justify. Further, you may also wish to place the couplets on the left and right side, alternately. This is easily done, by
indenting the alternate couplet, to left and right side, equally.

At times, a particular line may not fit all the words. Some words may spill over to the next line. To remedy this, 
either increase the Text Block size, by dragging its Handles, or decrease the overall font size.

There is a special character which you can use for the ‘Takhallus’ ( poet’s pseudonym ). This differs from Keyboard 
to Keyboard. Check your Keyboard layout for this special character.



How do I Compose Advertisements ?

Advertisements are more complicated than regular composing work.

An advertisement. is an arrangement of :-

1. Various    Text Blocks 

2. Pictures (which you can paste from the Clipboard or Insert).

3. Shapes and figures - Lines, Rectangles, Circles 

Alignment and proper layout are very important in an advertisement. To achieve this, it is better to create 
advertisements as a separate document and then Copy and Paste it to where-ever required. 

Extensively use Guides to suitably align all the items of an advertisement.

Should you wish to to create complex layouts, it will be possible to overlap items, one    over the other.

To copy a complete advertisement:-, 

1. Select the entire advertisement, by drawing a rectangle, enclosing all the items of the advertisement.

2. Choose Copy from Edit menu.



How do I Compose Magazines ?

Magazines typically have between 20 to 200 pages.    They are usually printed in sizes between demi and A4, with 
either a two or three column format. Each magazine has a typical text and heading style. 

With these aspects in mind, it is better to determine the style first and then create a blank document, with the page 
size, page margins and columns. Also create the Text Styles for the body text and standard headings.    Setup the 
headers, footers and Page Number Markers    on the Master Page of the blank document. Creat a file of this doc.for 
future use

We suggest that, for each issue of your magazine, you can open this blank file, save it under a different name for 
each issue, and compose your magazine in it.

The ads can be stored in separate files, and from there, Pasted into the document being composed. This will save on 
time, obviously.

You will have to separately compose the list of contents, once the rest of the magazine is ready.This is    because, 
until then, you would not know the page wise location of the various articles.



How do I Compose Newspapers ?

Newspapers are required to be composed quickly and with ease. 

With these aspects in mind,we suggest that, it is better to determine the style first and then create a blank document, 
with the Page Size, page margins and Columns (usually 8 columns of 45 mm each.) Also create the Text Styles for 
the body text and standard headings. of a single, double and triple column news. Setup the    headers, footers and 
Page Number Markers on the master page of the blank document. Create a file of this document for future use

We also suggest that, for each issue of your, news paper, you can open this blank file, save it under a different name 
for each issue, and compose your news paper in it.

The advertisements can be stored in separate files, and from there, Pasted into the document being composed. This 
will save on time, obviously

Use the Urdu Text Editor, especially provided for editing stories, as a separate UCS file.

Keep the AutoflowOFF and Manually Flow each news item. 



How do I Compose Books?

Each book will require a different font, size, etc. Books are generally published in a single column format, unless the
page size is close to    A4. In such cases, it would be better to split the page into two columns. Otherwise, the 
columns will be too wide for comfortable reading.

Sets-up the Styles for body text, sub-headings and headings. Use the Paragraph Setting - Always on Top of the 
Column, to break the text into chapters.

Set up the Master Page to display the book name and the Page Number on each page of the book.



How do I Use Styles ?

You can optimally exploit the potential of the    PageComposer 3,    by learning to use    Styles. You can then achieve 
a consistent and a clean layout of all your publications.

We suggest that, you classify the text into various categories, such as, the Headlines, Body Matter, Sub-headings, 
etc., and then create Styles for each category. By applying a typical style to the respective part of your document 
text, you can change the respective Format, by modifying its Style setting.

See Also Text::Style, Text::Define Styles



How do I Use Guides ?

Guides are non-printing lines on the page that help you align the various items on it.

There are two types of guides:

1. Column guides: These guides are created by Columns option of Layout menu. You can move the column guides 
by dragging them with left Button on the Mouse.

2. User Guides: These are created by dragging them out of the Horizontal or Vertical Rulers. You can remove these 
Guides by dragging them outside the page.

If the Snap to Guides option of the Layout menu is ON, then the items align themselves to the guide that is closer.



How do I Use OLE ?

OLE is a very powerful way of using the PageComposer 3. With OLE, you can insert items created by any of the 
thousands of OLE compatible programs. Almost all the standard Windows programs now support OLE.

To a create new item using any of the OLE programs, proceed as follows:-

Choose Insert Object from the Edit menu. Choose an OLE program that you wish to use. For instance, you can 
choose MS-Word to create an English text item or PaintBrush to create a simple picture. The PageComposer 3 will 
automatically launch the OLE program chosen. Once you have completed editing the new OLE item, select 
File::Exit to get back to the    PageComposer 3.

The OLE item will now appear on the page; approximately two inches from the top left hand side of the page. Move 
the item where you wish to place it .Re-size it, by dragging its Handle.

To further edit the OLE item on the page, double Click on it.This will launch the program which originally created 
the OLE object.

You can also place files that were created by OLE server programs.

To place a file as an OLE item:- 

1. Choose Insert Object from the Edit menu. Choose Create from file in the dialog.

2. From the list of files displayed, choose the file to be placed on the page and Click OK.

The file’s contents will now appear on the page (approximately two inches from the top left hand side of the page).



How do I Make Headlines ?

Headlines require a more precise word and letter placement than the regular text.

To create a headline, first mark a new    Text Block. Type in the text using the required font and size. 

To move words closer to each other, use Ctrl + Backspace

To move words away from each other, use Ctrl + Space.



How do I Draw Rectangles, Circles and Lines ?

You can use the Drawing tools available in the toolbar just below the menu.

Choose the correct Line and Fill settings before drawing them.



How do I Print Pages Bigger than the Printer’s Page Size.

A page size that is bigger than that of the printer, cannot be printed as a whole.The problem can be solved by 
printing one part at a time and then sticking.

To print only a part of the page at a time:-

1. Click on the zero rulers marker icon (the one with intersecting rulers)

1. Click with the zero marker at the point which you wish to make the top-left corner of your page.

3. Choose Print from File Menu or Click on the printer icon.

4. Choose Selection Button in the Print dialog. Click on OK.



How do I Draw Rectangles, Circles and Lines ?

You can use the Drawing tools available in the toolbar just below the menu.

Choose the correct Line and Fill settings before drawing them.



How do I Draw Rectangles, Circles and Lines ?

You can use the Drawing tools available in the toolbar just below the menu.

Choose the correct Line and Fill settings before drawing them.



How do I Draw Rectangles, Circles and Lines ?

You can use the Drawing tools available in the toolbar just below the menu.

Choose the correct Line and Fill settings before drawing them.



Foreword
The PageComposer 3 establishes newer levels of performance and sophistication in the Urdu/Persian/Arabic 
Desktop Publishing. The PageComposer 3 is true 32 bit software, which can keep growing with your needs. It is also
by far the most popular software for Urdu.
The PageComposer 3 has taken three years to complete. We have tried to keep everybody happy by incorporating all
the suggestions that we received from hundreds of our clients across the World. 
This is also the first program of its sophistication to be available free of cost on the Internet.
The complete documentation of the software is being provided on line so that it is easy to distribute and package. 
Shafiq-ur-Rahman and I started initial work on this version of the PageComposer in 1995 December. By mid 1996, 
Ravi Shankar had completed the port to 32-bit Win32 platform and in January we finished the program. The 
PageComposer 3 (a short lived shareware version) was released in April 1997. After extensive feedback, we have 
now released the PageComposer 3, which is friendlier and faster.
Apart from Ravi and Shafiq, Rajeev Sharma has made the program much more stable and friendlier by discovering 
bugs, interacting with users and suggesting workarounds and better implementations. Sri Kumar ran the 
‘interference’, kept everything going and took care of everything.
The software has been developed on a shoestring budget. It was necessary to keep the features list small. We had to 
pick and choose only those features that were flexible and very useful. We hope you enjoy using the software as 
much as we enjoyed producing it.

Ashhar Farhan.



Basic Concepts of the PageComposer

The PageComposer organizes each document as number of pages. 
Each page can hold a number of objects like in the figure above.
Each text block, box, line is an object that you can move, resize, copy, paste and delete.
To place text at a particular place, first create a text block object there and then type text into it.
You select an object on the page by just clicking on it.

Objects
The selected object appears with a solid line around it.
The selected object also has eight small squares called “handles” around it, which can be used to move the object or 
change its shape.

Text Blocks
A text block is an individual object on the page. When you begin a new document a text block is automatically 



created on the top of the page. As you keep entering text in a text block, the text block keeps expanding from the 
bottom side until it reaches its maximum vertical size.
Each text block can be linked to another text block so that the text remaining at the end of a the text block will 
automatically flow to the next text block.
Each heading, column of text, boxed item is an individual text block.
Set Autoflow on to automatically insert more text blocks and pages as text in a block increases.
Fonts
PageComposer allows you set the English and Urdu point sizes and typefaces within a single font specification. This
will give you very good control over the relative sizes of Urdu and English text.
The PageComposer allows you to mix English and Urdu freely. It will also allow you to specify whether English is 
being written within Urdu text or Urdu within English text.
You pull words together or push them apart to form tight headlines and kerning.
PageComposer gives you a great degree of typographical control over the Nastaleeq text shapes.
Text Styles
Instead of specifying the fonts, alignment, indents, etc. For each heading or sub-heading, you can create styles for 
each type of text. For instance, you can create a text style called ‘Heading’ with Typeface Abid, point size 40, center 
aligned and no indents. Next when you are composing a Heading, you can just highlight the heading text and choose
‘Heading’ from the style list.
Text Styles make your publication look better and uniform throughout. 
Text Styles also make it easy to change all the Headings or text settings. If you need to change the font of all the 
Headings, instead of highlighting each individual heading and changing the font, you can just change the settings 
within the Heading style and the PageComposer will recompose the entire document with the new settings.
Master Page
A master page is transparent page whose contents appear on every page of the document. It is useful when you have 
to repeat certain things on each page of your document like page numbers, headers, footers and the logo.
Placing guides on the master page helps in laying out all the pages in a consistent manner. These guides will be 
visible on every page.



Lesson 1: Opening, viewing and closing the publication.
The PageComposer allows you to view either the whole page or just a portion of the whole page.
Let’s learn this.
· Start the PageComposer. The PageComposer always opens with a blank document. 
· Click the right mouse button to see the full view of the page
· Move the mouse cursor to the top right corner of the page and right click again to see the right top part of the 

page in detail (zoomed in view).
· Type some rubbish into the text block. 
· Change the view to full page again to see the complete page view. The text will appear so small on the full-page

view that it will be unreadable.
Tip: To quickly view another part of the page right click to change to full page, move the mouse cursor over to 
whichever part of the page you wish to see in detail, and click the right mouse button again.
To move between pages
You can move between the page by using Page-Up or Page-Down keys.
You can open the “Goto page…” dialog by choosing “Goto page…” from the View menu.
You can move to the master page by selecting “Goto Master Page” from the View menu.
Changing the setting of the detailed view
The page can be viewed completely (the full view) or in detail (the detailed view). The magnification factor for the 
detailed view can be 200%, 100%, 50% or 25%. Usually for A4 sizes and smaller documents 50% is comfortable. 
For newspaper you need to work in 25% view.
You can choose the detailed view setting from the View menu.



Lesson 2: Typing text. 
To change between Urdu and English use Alt-L
PageComposer allows to type in Urdu as well as English. 
· Start the PageComposer
· Start typing. The text will appear in Urdu.
· To switch to English press Alt-L. (‘L’ for Language)
· Type some text in English (notice that the English matter move to the left)
· To switch back to Urdu press Alt-L again.
As you keep typing, the text block will keep expanding to fill the complete page. You can continue typing into the 
next column or page (we will come to that in Lesson 8).

The Urdu Keyboard
In the PageComposer, Choose “Show Keyboard…” from the View menu to see the current keyboard layout. You can
also press Ctrl+K to see the keyboard layout. Press Esc key to dismiss the keyboard layout from the screen.
The PageComposer comes with two standard Urdu keyboards. 
Muqtadra Urdu Keyboard: This is the ‘official’ Urdu keyboard. This is also the most popular keyboard layout.
Phonetic Urdu Keyboard: The Phonetic Urdu keyboard is very easy to use (especially if you are used to English 
QWERTY keyboard).
Depending upon where you obtained you copy of the PageComposer, anyone of these keyboards will be set for you. 
You can easily change the keyboard layout. See changing the keyboard layout

Typing Urdu Nastaleeq
The Urdu Nastaleeq is indeed a beautiful script. It uses subtle nuances of typography to enhance the beauty of the 
script. The PageComposer helps you do that by providing multiple ways of writing the same words. For instance 
consider the various ways in which the same phrase is written below:

The stylistic variations are introduced by typing and underscore ‘_’ key between two letters of a word. This is best 
understood if you try typing it yourself.
At times, you may wish to reduce gap between two words. You can do this by positioning the blinking caret (a 
vertical line which tell you where you are typing) between the two words by typing Ctrl-Backspace. Type Ctrl-
Backspace repeatedly to move the words closer and closer.
To introduce space between words, you can use Ctrl-Space between the words.

Cutting, Copying and Pasting text from one place to another
To paste text, first it has to be selected. The selected text appears in reverse on the screen. You can select the text 
either with the keyboard or the mouse.

Selecting Text with the mouse Move mouse over the first word to be selected, hold the left mouse button down
and drag to the last word to be selected in the text block. Release the mouse. The selected text should now 
appear in reverse.



Selecting Text with the keyboard Move the blinking caret (a vertical line which tell you where you are typing)
to the position before the first word to be selected. Hold the Shift key down and use arrow keys, END key and 
down key to extend the selection.

Once a selection is made, you can copy the selection or cut the selection. If you cut the selection, it is removed from 
the text block. The cut or the copied selection is held in the computer’s clipboard and it can be pasted into any text 
block even of another document.

Cutting or Copying Selected Text To copy or cut the selected text choose “Copy” or “Cut” from the Edit 
menu. You may also press Ctrl-C or Ctrl-X to copy or cut respectively instead of choosing the menu item.
Pasting Selected text Place the caret where you want to insert the text and choose “Paste” from the Edit menu. 
You may also press Ctrl-V instead of choosing the menu item.

Learn more about Text formatting and styles in Lessons 6,7,8 and 9.



Lesson 3: Basic Object handling techniques.
The PageComposer organizes its documents as pages. Each page has a number of objects on it. Each object is within
held within a rectangular area. The basic task of PageComposer is to help you place these objects on the pages and 
to allow you to manipulate and edit these objects to achieve a good layout. The PageComposer can create many 
useful objects like Urdu text blocks, rectangles, circles, lines, etc. You can also use objects created by other 
programs. This is dealt with in Lesson 11.
PageComposer can create the following objects on its own:
· Text Blocks. Each column, heading is a text block. To place text at a specific part of the page, you must create a

text block and type text in it. By placing text in blocks, you can move the complete block (for instance a 
heading) to any place in the page or even to another program. 

· Rules and Lines. Horizontal and Vertical rules(lines) are used in almost every publication. You can create either
single or double lines of any thickness. You can also choose any color for the lines

· Rectangle. The most commonly used graphic element is a rectangle. It is used as border around graphics, boxed
text-blocks, headings, etc. The rectangle can be drawn using either single or double line of any thickness(s) and 
color. The inside of the rectangles can be filled with any color and any one of the twenty supplied patterns. The 
rectangles can have either sharp corners or rounded corners.

· Circles and Ovals.  A circle or an oval too can be drawn just like the rectangle with any type and color of line, 
pattern and it can either be filled inside or be empty.

· Creating Text columns
· A text column is a regular text block that is automatically created and aligned between the column guides.
To create a text column, 
· Click on the above shown icon or choose “Text block” from Insert menu. 
· The mouse cursor will change to a text block.
· Move the text block cursor to the place on the page where you want to create a new column and click.

Creating Text blocks
0 To create a text block
· Click on the above shown icon or choose “Text block” from Insert menu. 
· The mouse cursor will change to a text block.
· Move the text block cursor to the place on the page where you want to create a new column.
· Hold down the left mouse button and drag the mouse to mark the area for the new text block.

Creating Graphic Objects
· Choose    “Line”, “Rectangle”, “Rounded Rectangle” or “Circle” from the Insert menu. You may also click on 

the appropriate icon from the toolbar instead.

· The mouse cursor will change to a cross bar like this    +.
· Move to the page. Hold the left button down and drag the mouse to draw the graphic object.
You can change the line and fill settings of the graphic object by selecting it and opening either “Line …” or “Fill 
…” from Layout menu.

Moving an object
· Select the object to be moved by clicking on it.
· Move the mouse cursor over the selected object’s boundary rectangle until the mouse cursor changes to four-

way arrow.
· Hold the left mouse button down and move the mouse (the object will also move along) to a new place.

Resizing an object
· Select the object to be resized
· Move the mouse cursor over any of the selected object’s handles until the mouse cursor changes to a double 

arrow.
· Hold the left mouse button down and drag the mouse to change size of the selected object.
To change the size of an object to some precise measurement, you can select the object (by clicking on it) and open 
the “Size …” dialog from the Layout menu. Here you can set the new width as well as the new height of the object.



Deleting an object
To delete an object, select it and press the Delete key or choose “Delete” from the Edit menu. If the block to be 
deleted is a text block, then pressing the Delete key or choosing “Delete” from Edit menu will only delete the text 
selection within the text block. There are two ways of deleting the complete text block.

1 Remove all the text from the block by selecting the text block, choosing “Select All” from the Edit menu and 
then pressing Delete key. The empty text block will automatically disappear.

2 Choose the frame by drawing a selection around it and then press Delete or choose “Delete” from the Edit 
menu. To draw the selection, move the mouse cursor just to the left and above the top left corner of the frame, 
holding the left mouse button down draw a rectangle to completely enclose the frame. More of this in the next 
Lesson.



Lesson 4: Cutting, Copying and Pasting objects
You need to select the objects that you wish to cut or copy first. If you have to copy just a single object, it is easily 
selected by just clicking inside it. However, you may at times wish to a set of objects. (For instance, an 
advertisement for your magazine may consist of five or six individual objects like the border rectangle, the text, the 
picture, a heading, etc.).

Selecting multiple objects
Move the mouse cursor to a place on the page away from any object.
Keep the left mouse button pressed and drag the mouse to draw a rectangle around all the objects to be selected.
Release the mouse buttons and the selected objects will be highlighted with a dotted 
rectangle around them.

Copy or Cut the selection, by choosing “Cut” or “Copy” from “Edit” menu.
Move multiple selection on the page by moving the mouse over any of the selected objects and dragging the mouse
while keeping the left mouse button pressed. Release the mouse button to stop moving.



Lesson 5. Using different fonts
PageComposer is a bilingual software. Each font setting of the PageComposer allows you choose individual 
typefaces for Urdu and English. Choosing “Fonts…” from Text menu opens the Font dialog.

As you can see there is a separate selection for Urdu and English fonts. This is done so that you can type in any 
combination of Urdu and English. 
You can use the font dialog to choose a new font for typing or to change the font of the existing type. You can also 
use the text toolbar to choose a new typeface or size for your text.

To type in English Press Alt-L to change the keyboard to English Keyboard
To type in Urdu Press Alt-L to change back the keyboard to Urdu.
To see the keyboard layout press Ctrl-K or choose “Show keyboard” from the View menu

To change the font of your text
· Select the text using the keyboard or the mouse as shown at the end of Lesson 2.
· Open the font dialog box by either pressing Ctrl-T or choosing “Fonts …” from Text menu. Change the font 

setting and click OK.
· Alternatively, you can directly choose a new typeface, a different point size from the text format bar at the top 

of the screen.



Lesson 6: Alignment of text.
Text paragraphs can be aligned either to the left or right or the center of the its block. Text can also be made to 
stretch from one side of the text block to another. This type of alignment is called “Forced”. 
Text can also be justified. A paragraph of justified text evenly ends all the lines of a paragraph. This is the usual 
setting for paragraphs in books with large running matter (like novels and short story collections). You can set if off 
so that each line appear to be of different length (depending upon the number of words in the line and their lengths).

To change the alignment of a particular text
· Select the text. If no text is selected, then the alignment will apply to the current paragraph or the text that will 

be entered next.
· Select the either left, right, center or forced alignment from the Text menu.
You can also select a new paragraph alignment by opening the paragraph dialog box by choosing “paragraph …” 
from Text menu or pressing Ctrl-P.



Lesson 7: Making linked text blocks.
In the previous lessons learnt using the text blocks. We have seen how to create, resize, move, copy, cut and paste. 
Now we introduce an important feature of the PageComposer – Linked text blocks. 
Most often, the text to be composed runs into many pages. While, the PageComposer has been used to create just 
small text blocks on a single page. We need a way to make the text of one block automatically flow into the next 
one. To do this, we have to create a continuation text block. Let’s see how this is done.
· Start the PageComposer and open the Layout menu. If the “Autoflow” item of Layout menu has a tick against it,

select it once to disable Autoflow (otherwise this example will not work properly).
· Now start a new publication by choosing “New” from the File menu.
· Type some 7-8 lines of text in the block automatically created in the new document.
· Now use the mouse to resize the text block such that it holds only 4 lines of text.
Now we have a text block with text than it can display. We need to add a continuation block to hold the remaining 
text.
· Move the mouse cursor to the bottom most handle of the text block and click on it.
· The mouse cursor shape will change to text block shape.
· With the text block cursor, draw the continuation frame on some other part of the page. (You can switch to the 

next page too by pressing Page-Down).
Most of the time when you are using the PageComposer to compose letters, or simple books, you need to keep 
adding continuation text blocks. It is tedious to add the continuation text blocks each time. 
There is a simpler way of doing automatically adding continuation text blocks and additional pages as you keep 
running out of pages in the document. It is called Autoflow. We will study Autoflow in the next lesson.



Lesson 8: Automatic text flow.
If you are composing a book or a regular magazine, text has to flow from column to column, adding pages as 
necessary. These columns of text are nothing but a series of linked text blocks (as described in the previous lesson). 
If you are not composing a very complicated document like an ad or a poster or a newspaper, it is best to allow 
PageComposer to do all the text flow for you.
To use the Autoflow feature,
· Start the PageComposer and open the Layout menu. If the “Autoflow” item of Layout menu does not have a 

tick against it, select it once to enable Autoflow.
· Start a new document by selecting “New” from the File menu.
· Now keep typing text in the text block of the newly created document. When the text reached the bottom margin

of the page, a new page will be added and the text will continue on the next page.
Usually the new documents have only one column per page. For a multiple column document, you have to first 
create multiple columns and then flow text into the multiple columns.

Using Autoflow with multiple columns
· Start the PageComposer and open the Layout menu. If the “Autoflow” item of Layout menu does not have a 

tick against it, select it once to enable Autoflow.
· Start a new document by selecting “New” from the File menu.
· Choose “Columns …” from Layout menu to get the columns dialog. Choose let’s say 3 columns and a gap 

of .5cms between them. Click Ok to remove the dialog box and create the columns on the current page.
· Click on the text block icon from the tool bar and click inside the first column (the right-most column for Urdu 

documents) to create a text block.
· Keep typing text in the new text block in the first column. When the first column is full, the text will 

automatically start in the next column.
If text block A is linked to text block B, then decreasing the size of text block A will force the rest of the text to 
automatically flow into the B block.



Lesson 9: Using the accompanying text editor
You can use more than one computers to enter text for composing on your PageComposer. The Text Editor supplied 
along with the PageComposer will help you use any number of inexpensive small computers to do data entry in 
Urdu. This data can later be used to compose pages in PageComposer. This is a really powerful tool if you are 
planning to use PageComposer for high volume work (like printing books or newspapers).

The Text Editor    consists of the following files:
TE.EXE,
URDU.FNT
EGAVGA.BGI
CGA.BGI
HGA.BGI
ATT.BGI
IBM8514.BGI
PC3270.BGI

The Text Editor is not copy protected and you can install it on any type of personal computer ranging from a single 
drive PC/XT to a Pentium Pro. It will also work under any operating system from DOS 3.3 to Windows Advance NT
server.

Using the Text Editor, you can enter text in Urdu on any number of small computers. The Text Editor program 
TE.EXE will create files with UCS extension (like URDU.UCS).    These files can be inserted in the PageComposer 
3.

Using the Text Editor
· To install the text editor, copy all the files listed above into a directory on your computer.
· Run TE.EXE. The Text Editor uses only the Muqtadera Keyboard layout. Press F1 to get the help screen of TE.
· Save the files with .UCS extension.

The .UCS files created in TE can be easily inserted in any PageComposer document. For example, there is a sample 
UCS file called TEST.UCS supplied with the software. We will place it in a fresh PageComposer document.

Placing a UCS file
· Start the PageComposer. The PageComposer starts with a new document and automatically creates and selects a

text block for you.
· With the text block selected, choose “Text file …” from Insert menu. A file dialog will open choose 
SAMPLE.UCS file present in your PageComposer directory.

The contents of SAMPEL.UCS will be transferred onto the PageComposer document. If the Autoflow was enabled, 
then extra text blocks and pages will also be created.
The Text Editor is also capable of working with text styles. More of than is given in the chapter on Using Text Styles
with the text editor.



Lesson 10: Inserting objects created by other programs
We have seen in Lesson 3 that PageComposer allows us to create simple graphical objects like rectangles and line. 
However, we also need to include more elaborate things like equations, charts, illustrations, etc. in our documents. 
Very powerful programs are available that will allow us to use create really beautiful objects. These programs are 
called OLE server programs. Most of the programs that you will use under Windows like Corel-Draw, Adobe-
Photoshop, MS-Office are all OLE complaint. You can insert objects (saved as files on the hard disk) into the 
PageComposer documents. 

To insert an OLE object 
· From the Insert menu, choose “Object …” item. The OLE Insert Object dialog appears on the screen.
· Choose “Create from file” in the dialog.
· Now we have to choose a file created by an OLE program. All version of Windows come with a Paintbrush 

accessory. The Paintbrush can create BMP files. So choose a BMP file (there are quite a few of them in the 
Windows directory.). Click OK.

· The BMP file will appear on the current page of the PageComposer.

0 You can similarly choose any file created by an OLE program. However, to load the file into PageComposer, 
you also need that program to be installed on your machine. For instance, if you want to place a file 
“MYLETTER.DOC” created in MS-Word, you should also have MS-Word installed on your system.

1 You can also use any of the OLE programs to create objects as and when required instead of choosing files 
already created.

2  To create an new OLE object
· From the Insert menu, choose “Object …” item. The OLE Insert Object dialog appears on the screen.
· Choose “Create new” in the dialog.
· Now we have to an OLE program. All version of Windows come with a Paintbrush accessory. The Paintbrush 

can create BMP files. So choose the Paintbrush program from the list of programs in the dialog box. 
· The chosen program will start (in this case the Paintbrush). Create the object (draw something in the Paintbrush)

and exit. If the program asks you if it should update PageComposer document, choose Yes.
· The newly created object will appear on the PageComposer’s current page.

The OLE objects resize, move, copy, cut and paste just like all the other objects.



Graphics
A principal feature of the PageComposer is to combine text and graphics together. The PageComposer draws lines, 
circles and rectangles of any size, shape and thickness. It can use single or double lines of varying thickness (even 
the gap between two lines of a double line can be controlled).
Apart from the in-built graphics, the PageComposer can access hundreds of other Windows programs to create 
graphics. For instance, you could type out a heading in a text block, copy the text block, paste it in Adobe 
Photoshop, add special effects to it and paste it back into the PageComposer.

Layout
Layout refers to the act of planning your page and deciding on the number of columns, the overall look, size and 
appearance of the page. 
To assist you in layouts, the PageComposer provides you with Column Guides as well as User Guides.
The Column Guides mark the areas of a page that are to be filled with text. 
To create columns
· Choose “Columns…” from Layout menu. The columns dialog will appear
· In the dialog, type the number of columns needed on the page. You can also adjust the gaps between columns by

typing in the required gap.
· Click the dialog’s ok button. The fresh columns will now appear on the page
The columns that are created by the PageComposer are of equal size. To increase or decrease the size of a column, 
use the mouse cursor to drag the column guides.
· Move the mouse cursor over a column guide such that there is no object under the mouse cursor. (If there is 

some object under the mouse cursor, it may get selected!).
· Hold the left mouse button down and drag the column guide to a new place.

The User Guides are often used to logically divide the page into various parts. For instance a horizontal guide 
running across the top of the page may separate the headings area from the story area. A Guide may also be used to 
align two objects that don’t exactly fall on any column margin.
To create a user guide
· Move the mouse cursor over any of the rulers.
· Hold the left button down and move the mouse (without leaving the left button) to the page.
· Leave the guide wherever it is required on the page.
The user guides are only possible within the page. For instance, if you were to pull a guide and leave it at a place 
outside the page, it will be removed.    That is how you can remove a guide.

Creating Tables
PageComposer has a really simple way of creating table. While editing text, use the Tab key shift your matter about 
5mm at a time. You can create any table by simply using the Tab key.

Lines and Borders
You can create a wide variety of lines for your publication. Each line’s appearance depends upon:
· The thickness of the line (this is to be specified in point like this “2pt”)
· The color of the line.
· Incase, a double line is required, the distance of the second line from the first (again in Points) and the thickness

of the second line itself.
These are some of the lines created in PageComposer. You are free to create your own.



Patterns
Circles and Rectangles can also be filled inside. A filled object will hide the object behind it. Like this:

To choose fill attributes
· Select “Fill…” from Layout menu. The Fill dialog will appear
· In the fill dialog, choose any fill pattern from the list box. Click on the color button to choose a color from 

palette. Click on OK to accept the new settings
· If a graphic object was selected, the new fill settings will apply to it. The new settings will also apply to the new

rectangles and circles being drawn.

Text Wrap

Text wrap makes the PageComposer flow text around another object. Like in the figure above.
Notice that the main text in the above paragraph flows around the circle and also around another text block on the 
left (which is now looking like a drop word).
The text inside the circle wraps inside the circle while the text of the main paragraph wraps outside the circle.

To use text wrap
· Select an object around which you would like to wrap text.
· With the object selected, choose “Text wrap…” from Layout menu. The text wrap dialog will appear.
· Set the checkbox in the Text wrap dialog.
· The Text Wrap dialog box also lets us specify how much margin is to be left on all the sides around the 

“wrapped” object.
· Click on Ok in the text wrap dialog. 
If the text wrap is enabled for a circle or rectangle object, all the text block lying fully inside the are wrapped from 
inside like the text in the above circle. Any text block that only partially overlaps the wrapped object is wrapped 
from the outside.





More About Text
The basics of text are discussed in the Lessons 2,5,6,7 and 8. Here we will learn about the more powerful features of
the PageComposer like Styles, Indents and composing Poetry etc.

Styles
Styles are an important way to use the PageComposer. You should learn to effectively use Styles in order to achieve 
a consistent and clean layout.

You can classify text into various categories like headlines, body matter, sub-headings, etc. Style for these various 
categories can be created. Instead of specifying font, alignment, leading (spacing between lines) etc. each time a 
sub-head has to be formatted, you can just specify a style and all the settings of that style will automatically apply to 
the selected text. Later, if you change the settings of a particular style, the complete document will be recomposed 
automatically to reflect the changed style. 

Every publication has atleast one style called “Body”. Let’s see the settings of Body.
· Choose “Define Styles…” from the Text menu to get the Style definition dialog. (You can also press Ctrl+3)
· Choose the “Body” style. Now click on Fonts, Paragraph or Indents buttons to see their settings.

Try typing something in a blank document.    Select the text and choose “Body” from the style box (the left most box
on the text tool bar at the top of PageComposer’s main window). Now open the Style Definition dialog (by pressing 
Ctrl+3); try changing various settings of Body style. Close the dialog and observe how the text is automatically 
reformatted according to the change you made in the Style definition.

To create a new style
· Open the style definition dialog by either choosing “Define styles…” from Text menu or by pressing Ctrl+3.
· Click on New button of the dialog.
· Another dialog will pop out type the name of the new style. Click on Ok.
· The new style name will appear in the list of styles. Select the new style from the list and edit its font, paragraph

and indent settings whichever way you need them.
· Close the Styles definition box by clicking on Ok.

Using Styles with the Text Editor
Styles can also be specified in the UCS file that you will import into the PageComposer.    This gives you a very easy
way specifying the text format from the Text Editor itself. (For more details on the text editor, see Lesson 10). The 
text editor is a very powerful way of using the PageComposer and it is definitely worth learning.
To specify a text style “Body”, in the Text editor type “\Body” on the first line of the text that has to be formatted in 
“Body” style. The SAMPLE.UCS has two styles specified in it: a “Heading” style for the headline text and “Body” 
for the rest. You can load the SAMPLE.UCS into the text editor to view it.
Remember that the style name always appears at the beginning of a paragraph and it is preceded with a ‘\’ (a back 
slash). To type the character ‘\’ in the text editor, type ‘\\’ instead.

Indents
When you want text to be offset a little from left and right    (for instance, a small gap before the first word on the 
first line of a paragraph), we say that we want the text to be indented.

A convention is to leave extra space at the beginning of the first line of a paragraph. This is effectively, indenting the
first line of the paragraph. We call this the paragraph indent. You can specify both para-indents as well as regular 
indents (which apply not only to the first line of the paragraph but to all the lines). For instance, if the regular 
indents are 1cm from the left, 1.5 cm from the right sides and 0.5cm para-indent, then, this is how that paragraph 
will appear:



The indents can be from the Indents dialog. To get the indents dialog, choose “Indents…” from “Text” menu or 
press Ctrl+I.

Poetry
Poetry requires lines of equal lengths. You can do this by changing the alignment of the whole poem to “Forced 
Justify”. Further, you may want the alternate the couplets to be pushed to left and right sides. This is easily done by 
alternatively indenting each couplet to left and right by equal amounts.

At times, a particular line may not fit all the words. Some words may spill to the next line. To remedy this you can 
try kerning the words in the line to move them closer, decrease the font width or increase the size of the complete 
text block holding the text.

Headlines
Urdu, Arabic and Persian headlines are often complete sentences and it is often required to fit them into small areas. 
To achieve this, you can kern to move the words closer (by typing Ctrl+Backspace between them) or you can reduce
the font size (or just the font width) until the headline fits in properly.
At times, the headlines have to be in reverse (white text on black background). 

To draw reverse headlines
· Select the text and open the font dialog box (by choosing “Fonts…” from the Text menu). Click on the color 

button and choose white color from the color palette. Click on OK to close the dialogs.
· The text will now turn to white (as a result you will not be able to see it). 
· Draw a rectangle to approximately cover the headline. 
· Select the rectangle by clicking on it. Fill it with black color (Open the Fill dialog by choosing the “Fill…” item

from “Layout” menu. Click on the color button and choose Black color from the palette. Close the dialogs by 
clicking on Ok buttons)

· The rectangle is probably on top of the text. To send the rectangle to the back, Choose “Send to back” from the 
Layout menu (or Press Ctrl+B).

Copying Urdu text into another program



At times, you may want to use any of the graphics software to make an elaborate heading. In that case, you may 
want to copy a whole text block as a graphic image. 

To copy a Urdu text block as a graphic image
· Select the text block by dragging the mouse cursor around it (as shown in Lesson 4’s “Selecting multiple 

objects”).
· Choose “Copy” from the edit menu or press Ctrl-C.
· Switch to another graphics program and Paste the text block in it.






